Release Date

7th September 2021.

Overview

Due to a vulnerability in the Go crypto/tls package, if Ava Aware or an Ava camera was to perform a secure TLS connection to a malicious server then it would be possible for the server to perform an invalid handshake causing an application restart.

Affected Products

  • Ava Aware:
    • All Stable upgrade channel versions before 3.8.4.
    • All Beta upgrade channel versions before 4.0.2.
  • Ava Cameras:
    • All Stable upgrade Channel versions before 3.8.4.
    • All Beta upgrade channel versions before 4.0.2.

Unaffected Products

  • Ava Aware:
    • All Stable upgrade channel versions after and including 3.8.4.
    • All Beta upgrade channel versions after and including 4.0.2.
  • Ava Cameras:
    • All Stable upgrade channel versions after and including 3.8.4.
    • All Beta upgrade channel versions after and including 4.0.2.
  • Ava Cloud: all versions

Resolution

This issue has been fixed in Ava Aware Beta upgrade channel version 4.0.2 and Stable upgrade channel version 3.8.4.

It is strongly recommended that all installations running an affected version are upgraded to the latest release as soon as possible. Releases are available to download through the Ava Aware User Interface.

This issue has been fixed in Ava Camera Beta upgrade channel version 4.0.2 and Stable upgrade channel version 3.8.4.

It is strongly recommended that all that all Ava Camera installations running an affected version upgrade to the latest release as soon as possible. Releases are available to download through the Ava Aware User Interface for Ava managed cameras and the Ava Camera User Interface for unmanaged Ava cameras.

Vulnerability Information

Mitigations

There are no known mitigations for this issue.

Work arounds

There are no known work arounds for this issue.

Acknowledgements

Issue found and reported to The Go Team by Imre Rad.

Disclosure Timeline

  • 12/06/2021 Issue found by Imre Rad
  • 15/06/2021 Patched Ava Aware (Beta upgrade channel) released
  • 15/06/2021 Preliminary vulnerability advisory published
  • 19/06/2021 Patched Ava Aware (Stable upgrade channel) released
  • 07/09/2021 Vulnerability publicly disclosed